IPCop-Forum.de

www.ipcop-forum.de


IPCop-Community
CL-Systems
Home Home   Doku Doku   Links Links   Downloads Downloads
UnIPCop Der (Un)IPCop   IFS IPCop-ForumSpy
CopTime CopTime   Galerie IPCop-Galerie   IPCop Userkarte Userkarte
Aktuelle Zeit: 11.12.2017, 14:11

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 26 Beiträge ]  Gehe zu Seite 1 2 Nächste
Autor Nachricht
 Betreff des Beitrags: APU2 Probleme Installation
BeitragVerfasst: 24.08.2016, 15:28 
Offline
Constable
Themenstarter
Constable

Registriert: 12.01.2016
Beiträge: 34
Hallo,

auf unserm neuen APU2 kamen wir mit den Thread-Infos in http://www.ipcop-forum.de/forum/viewtopic.php?f=55&t=31815 schonmal bis in die IPcop-v2.1.8-Installation hinein, sowohl mit einem USBstick wie auch mit USB-CDROM.

Wesentlich dabei war, nach der Zeile "Syslinux..." auch zu merken, dass da weiter oben plötzlich "boot:" aufgetaucht ist. Mit
Code:
install console=ttyS0,115200n8
gings dann richtig weiter und die IPcop-Installation startete.

Kurze Zeit später jedoch sollte die Installationsquelle gewählt werden, aber die Auswahl
Code:
CDROM/USB-Key
war zwar logisch, aber unmöglich:
Code:
No CDROM found.

Nun stehen wir auf dem Schlauch. Hat denn die APU2 einen so seltsamen USB-Controller, dass die IPcop-Installation nichts damit anfangen kann?

Nach dem USB-Controller frisch gegugelt, fand sich http://forums.debian.net/viewtopic.php?t=129092 in Debian mit lspci folgende Info:
Code:
00:10.0 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD] FCH USB XHCI Controller [1022:7814] (rev 11)

Also nach Vendor 1022 und Device 7814 gesucht, das ergibt jedoch nur ein wenig informatives
Code:
AMD USB 3.0 Host Controller

Klingt eigentlich nach einem Wald- & Wiesenchip, so gewöhnlich wie Brot. Oder?

Um mal weiter zu schauen was andere Systeme von der APU2 halten:
<offtopic>
Wir haben inzwischen mal testweise eine Debian 8.2 Netinst-CD im USB-CDROM gestartet, und siehe da: GRUB lief auf Anhieb über den Serial Port, aber die Kernel-Bootparameter mußten angepasst werden:
Im Installationseintrag ersetzen
Code:
vga=788
durch
Code:
console=ttyS0,115200n8

Nach der völlig problemlosen Installation und reboot ist dasselbe nochmal fällig um nicht blind zu fliegen;
anschließend in /etc/default/grub ersetzen
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
durch
Code:
GRUB_CMDLINE_LINUX_DEFAULT="console=ttyS0,115200n8"
gefolgt vom Ausführen von
Code:
update-grub

And thus, Bob's your uncle.

Auch OpenWRT (openwrt-15.05.1-x86-64-combined-ext4.img) startet unverändert vom USB-Stick, kennt in der Version aber die Intel-LAN-Chips nicht.
</offtopic>

Und IPcop mit seiner unerreichbaren "No CDROM found"?
Was tun, sprach Zeus, die Götter sind besoffen...

Ideen? Kernel-Boot-Optionen? Voodoo?
Wie sind für jedwede Tipps dankbar.

_________________
Mit freundlichen Grüßen,
-- UniNett


Nach oben
   
 Betreff des Beitrags: Re: APU2 Probleme Installation
BeitragVerfasst: 24.08.2016, 15:46 
Offline
Sergeant
Sergeant
Benutzeravatar

Registriert: 29.07.2006
Beiträge: 54
Hallo "United-Networking",

ich bin auch ein stolzer Besitzer eines APUs. Hier im Forum gibt es vile Hinweise dazu, auch viewtopic.php?f=58&t=31335. Damit sollte auch bei euch die Installation klappen.
Bei mir gings einwandfrei über einen USB-Stick.

Gruß
Andreas


Nach oben
   
 Betreff des Beitrags: Re: APU2 Probleme Installation
BeitragVerfasst: 24.08.2016, 16:20 
Offline
Constable
Themenstarter
Constable

Registriert: 12.01.2016
Beiträge: 34
Hallo,

joh, wär schön, wenn dem hier auch so wäre. Allein, IPcop 2.1.8 mag den APU2C2 hier net.
Vielleicht möcht's ja die 4GB-Version haben (Fürwahr, er hätte ihn getroffen! / wär nur der Bär nicht fort geloffen -- bzw. das CDROM...).
Von allen APU1*-Varianten freilich haben wir hier in den Foren den Eindruck gewonnen, dass die mittlerweile gut mit IPcop zusammenspielen.
Vive la difference, oder so ähnlich.

Bisher noch ausgelassene relevante Fakten:
    * Auf unserem USBstick bootete nur das Image ipcop-2.1.8-install-usb-fdd.i486.img.gz, mit Win32DiskImager auf USBstick kopiert. Nicht so das -hdd.
    * In der APU2 steckt eine Silicon Power SSD 16GB (S9FM02.8), die als Installationsziel herhalten soll.

_________________
Mit freundlichen Grüßen,
-- UniNett


Nach oben
   
 Betreff des Beitrags: Re: APU2 Probleme Installation
BeitragVerfasst: 24.08.2016, 16:27 
Offline
Sergeant
Sergeant
Benutzeravatar

Registriert: 29.07.2006
Beiträge: 54
Ich hatte seinerzeit die Installations mit einer älteren Version (mind. 2 Versionen) gemacht. Sollte aber auch mit der aktuellen Version kein soo großes Problem sein. Die C2 und C4 Versionen unterscheiden sich ja nur im RAM.

Gruß
Andreas


Nach oben
   
 Betreff des Beitrags: Re: APU2 Probleme Installation
BeitragVerfasst: 24.08.2016, 16:53 
Offline
Constable
Themenstarter
Constable

Registriert: 12.01.2016
Beiträge: 34
Hallo,

hmm, stimmt, die v2.1.1 ist in den diversen Threads öfter erwähnt worden. Wäre notfalls noch einen Versuch wert, wenn nicht noch jemand ne andere empfiehlt.
Allerdings waren m.W. die jüngsten Einträge zum Thema APU schon fast 1 Jahr alt und allesamt noch zur APU1, nicht zur APU2.
Und die APU2 hat scheinbar mindestens schonmal
    * Intel- statt RTL-LAN-Controller,
    * andere CPU,
    * neueres BIOS,
wenn nicht noch mehr Unterschiede. Siehe http://www.pcengines.ch/apu.htm und http://www.pcengines.ch/apu2.htm.
Wenn man sich die Hardware-Probleme anschaut, die Leute mit der APU1 hatten, sind diese Unterschiede wohl relevant.

_________________
Mit freundlichen Grüßen,
-- UniNett


Nach oben
   
 Betreff des Beitrags: Re: APU2 Probleme Installation
BeitragVerfasst: 25.08.2016, 08:16 
Offline
Chief Superintendent
Chief Superintendent

Registriert: 09.06.2006
Beiträge: 797
Hallo,
ich habe mit der 2.1.15 (i486-HDD) angefangen (höhere Versionen wollten nicht so recht).

Fred


Nach oben
   
 Betreff des Beitrags: Re: APU2 Probleme Installation
BeitragVerfasst: 25.08.2016, 10:13 
Offline
Constable
Themenstarter
Constable

Registriert: 12.01.2016
Beiträge: 34
Hallo,

wird "sofocht" getestet.

Welche Symptome traten bei den neueren Versionen denn noch so auf?

_________________
Mit freundlichen Grüßen,
-- UniNett


Nach oben
   
 Betreff des Beitrags: Re: APU2 Probleme Installation
BeitragVerfasst: 25.08.2016, 10:16 
Offline
Constable
Themenstarter
Constable

Registriert: 12.01.2016
Beiträge: 34
Hallo,

uuund wie gehabt,
Zitat:
No CD-ROM found.

Schad.
Also mal die 2.1.1 rauskramen...

_________________
Mit freundlichen Grüßen,
-- UniNett


Nach oben
   
 Betreff des Beitrags: Re: APU2 Probleme Installation
BeitragVerfasst: 25.08.2016, 10:28 
Offline
Constable
Themenstarter
Constable

Registriert: 12.01.2016
Beiträge: 34
Hallo,

während des Rauskramens eben noch die ipcop-2.1.5-install-usb-hdd.i486.img getestet:
Bootet (zu unserer Überraschung, die 2.1.8 tats ja nicht), tut aber exakt dasselbe (nicht).
Mal genau hingeschaut, kommt vor der Fehlermeldung kurz noch "Mounting CD-ROM".
Hat jemand eine Ahnung was da konkret gesucht wird? /dev/cdrom ist ja meist nur ein Symlink...

_________________
Mit freundlichen Grüßen,
-- UniNett


Nach oben
   
 Betreff des Beitrags: Re: APU2 Probleme Installation
BeitragVerfasst: 25.08.2016, 10:41 
Offline
Constable
Themenstarter
Constable

Registriert: 12.01.2016
Beiträge: 34
Hallo,

und auch die ipcop-2.1.1-install-usb-hdd.i486.img zeigt nix neues, sondern wie gehabt
Code:
No CD-ROM found.
:help:

_________________
Mit freundlichen Grüßen,
-- UniNett


Nach oben
   
 Betreff des Beitrags: Re: APU2 Probleme Installation
BeitragVerfasst: 25.08.2016, 10:47 
Offline
Chief Superintendent
Chief Superintendent

Registriert: 09.06.2006
Beiträge: 797
Hallo,
was sagt das pc-engines-Forum dazu?

(boot CD-rom .... USB)

Fred

ps: mein APCU2 war eine Auftragsarbeit(kannst du mal schnell helfen...), kann aktuell nix zu BIOS-Version usw. sagen.


Nach oben
   
 Betreff des Beitrags: Re: APU2 Probleme Installation
BeitragVerfasst: 25.08.2016, 11:05 
Offline
Constable
Themenstarter
Constable

Registriert: 12.01.2016
Beiträge: 34
Hallo,

von den 3 Resultaten bei http://www.pcengines.info/forums/?searc ... &sa=search enthält nur das letzte http://www.pcengines.info/forums/?page= ... 0E0DB05B2A eine beiläufige Erwähnung von IPcop 2.x. Ist aber 2 J. her und noch zu APU1.

Zu "No CD-ROM found" gibts nix, CDROM oder CD-ROM tauchen beiläufig in wenigen Stellen auf, aber dieser Fehler nicht.

Wir werden auch dort im Forum mal fragen, obwohl IPcop da nun wirklich kein Thema zu sein scheint.

_________________
Mit freundlichen Grüßen,
-- UniNett


Nach oben
   
 Betreff des Beitrags: Re: APU2 Probleme Installation
BeitragVerfasst: 25.08.2016, 13:04 
Offline
Site-Moderator
Site-Moderator
Benutzeravatar

Registriert: 18.12.2007
Beiträge: 3328
Wohnort: Im Norden bei mir zu Hause
United-Networking hat geschrieben:
Code:
No CD-ROM found.

Wenn du von einem USB-Stick installierst, wie groß ist dieser?

Könnte ein ähnliches Problem sein wie hier. Auch wenn es sich nicht um ein Hybrid-Image handelt.

_________________
Gruß edelweis

Sledgehammer engineering, if it doesn't work, hammer it damn hard :super:

Bild
Bild
Meine Vorstellung


Nach oben
   
 Betreff des Beitrags: Re: APU2 Probleme Installation
BeitragVerfasst: 25.08.2016, 13:46 
Offline
Constable
Themenstarter
Constable

Registriert: 12.01.2016
Beiträge: 34
Hallo,

die Installations-Images für IPcop liegen knapp unter 64MB ausgepackt.
Es gibt hier als kleinstes Medium zwar noch eine uralte SDkarte mit 32MB, aber für die APU2-Versuche nahmen wir einen Stick mit 4GB.

Überdies (wie erwähnt) alternativ auch die Installation in CD-Form (v2.1.8) in einem USB-CD-Laufwerk.

Alle Varianten zwar gratis, aber in dieser Situation umsonst. Nix klappte, und das auf identische Weise.

_________________
Mit freundlichen Grüßen,
-- UniNett


Nach oben
   
 Betreff des Beitrags: Re: APU2 Probleme Installation
BeitragVerfasst: 25.08.2016, 13:48 
Offline
Constable
Themenstarter
Constable

Registriert: 12.01.2016
Beiträge: 34
Hallo,

der Link unter "hier" führt nur zur Hauptseite des Forums; stimmt das so?

_________________
Mit freundlichen Grüßen,
-- UniNett


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 26 Beiträge ]  Gehe zu Seite 1 2 Nächste

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu Forum:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de