IPCop-Forum.de

www.ipcop-forum.de


IPCop-Community
CL-Systems
Home Home   Doku Doku   Links Links   Downloads Downloads
UnIPCop Der (Un)IPCop   IFS IPCop-ForumSpy
CopTime CopTime   Galerie IPCop-Galerie   IPCop Userkarte Userkarte
Aktuelle Zeit: 24.08.2017, 06:51

Alle Zeiten sind UTC+02:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 2 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Böses Entertain und der liebe IPCop
BeitragVerfasst: 03.05.2013, 14:00 
Offline
Rookie
Themenstarter
Rookie
Benutzeravatar

Registriert: 11.04.2013
Beiträge: 8
Hallo,
ich bin etwas auf dem Holzweg...mein erster Versuch das Entertain aus dem internen Netz zu berbannen ist nicht so ganz erfolgreich. 1. Gedanke war MR bleibt im roten Netz, DHCP auf dem Router bleibt an und er fungiert dann als Modem und der IPCop wählt selber. Läuft die ersten Stunden recht gut dann gehen aber immer mehr Fernsehkanäle verloren (Standbild/ Kein Bild)

Jetzt habe ich versucht den MR in ein eigenes Netz (GRAU) zu verbannen.

Erste Frage war hab ich VDSL oder nicht, aber nach Telekom Rechnung hab ich DSL16 Plus, steht also nichts von VDSL und wenn ich ein VLAN-Tag (7 oder 8) bei der Wahlverbindung eintrage, stehlt der IPCop nach 5min wählen immer noch keine Verbindung her.
Somit nehme ich an das ich kein VDSL habe.

Hab mich dann mal nach dem Thema versucht den IPCop einzurichten das der MR funktioniert.
viewtopic.php?f=57&t=30318&p=255308&hilit=entertain#p255308

Hab das ganze entsprechend meiner Interfaces angepasst
Code:
ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
2: unused-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:e0:4c:69:68:a3 brd ff:ff:ff:ff:ff:ff
    inet 192.168.131.1/24 scope global unused-1
3: lan-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ether 00:e0:4c:69:68:a4 brd ff:ff:ff:ff:ff:ff
    inet xyz.xy.0.2/16 scope global lan-1
4: wan-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ether 00:01:2e:4b:de:05 brd ff:ff:ff:ff:ff:ff
    inet 192.168.130.2/24 scope global wan-1
5: wlan-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 48:5d:60:48:01:c8 brd ff:ff:ff:ff:ff:ff
    inet xyz.yx.0.2/16 scope global wlan-1
6: mon.wlan-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UNKNOWN qlen 1000
    link/ieee802.11/radiotap 48:5d:60:48:01:c8 brd ff:ff:ff:ff:ff:ff


/etc/igmpproxy.conf:
Code:
 ------------------------------------------------------
## Enable Quickleave mode (Sends Leave instantly)
##------------------------------------------------------
quickleave


##------------------------------------------------------
## Configuration for ppp0 (Upstream Interface)
##------------------------------------------------------
phyint mom.wan-1  upstream  ratelimit 0  threshold 1
        altnet 10.0.0.0/8
        altnet 192.168.0.0/24
        altnet 217.0.119.194/24 #T-COM
        altnet 193.158.35.0/24  #T-COM
        altnet 192.168.131.200 # Receiver
        altnet 192.168.131.201 # Receiver
        altnet 192.168.131.202 # Receiver
        altnet 192.168.131.203 # Receiver

##------------------------------------------------------
## Configuration for lan-1 (Downstream Interface)
##------------------------------------------------------
phyint unused-1 downstream  ratelimit 0  threshold 1
        altnet 192.168.131.200 # Receiver
        altnet 192.168.131.201 # Receiver
        altnet 192.168.131.202 # Receiver
        altnet 192.168.131.203 # Receiver

##------------------------------------------------------
## Configuration for wlan1 (Disabled Interface)
##------------------------------------------------------
        phyint lo disabled
        phyint ppp0 disabled
        phyint wan-1 disabled
        phyint lan-1 disabled
        phyint mon.wlan-1 disabled
##    phyint unused-1 disabled


/etc/rc.d/rc.event.local:
Code:
### # START IP-TV
if [ ${1} == "red" -a ${2} == "up" ]; then
        echo "RED up, Starting IP TV"
        /sbin/modprobe 8021q
        /sbin/vconfig add wan-1
        /usr/sbin/dhcpcd wan-1

        /sbin/iptables -I CUSTOMFORWARD -s 193.158.35.0/24 -d 224.0.0.0/4 -i
        /sbin/iptables -I CUSTOMINPUT -d 224.0.0.0/4 -j ACCEPT -i wan-1
        /sbin/iptables -I CUSTOMFORWARD -s 217.0.119.0/24 -d 224.0.0.0/4 -i m
        /sbin/iptables -I CUSTOMFORWARD -d 224.0.0.0/4 -j ACCEPT
        /sbin/iptables -t nat -A CUSTOMPOSTROUTING -o wan-1 -d 87.141.128

        /usr/sbin/igmpproxy /etc/igmpproxy.conf &
fi
if [ ${1} == "red" -a ${2} == "down" ]; then
        /usr/bin/killall igmpproxy

        /sbin/iptables -D CUSTOMFORWARD -s 193.158.35.0/24 -d 224.0.0.0/4 -i
        /sbin/iptables -D CUSTOMINPUT -d 224.0.0.0/4 -j ACCEPT -i wan-1
        /sbin/iptables -D CUSTOMFORWARD -s 217.0.119.0/24 -d 224.0.0.0/4 -i m
        /sbin/iptables -D CUSTOMFORWARD -d 224.0.0.0/4 -j ACCEPT
        /sbin/iptables -t nat -A CUSTOMPOSTROUTING -o wan-1 -d 87.141.128

        /usr/bin/killall dhcpcd
        /sbin/vconfig rem wan-1
fi
### END IPTV

### mit diesen Regeln friert der Cop ein
if [ ${1} == "red" -a ${2} == "up" ]; then
        /sbin/modprobe 8021q
        /sbin/vconfig add wan-1
        /usr/sbin/dhcpcd wan-1

        /sbin/iptables -I CUSTOMFORWARD -s 193.158.35.0/24 -d 224.0.0.0/4 -i
        /sbin/iptables -I CUSTOMINPUT -d 224.0.0.0/4 -j ACCEPT -i wan-1
        /sbin/iptables -t nat -A CUSTOMPOSTROUTING -o wan-1 -j MASQUERADE

        /usr/sbin/igmpproxy /etc/igmpproxy.conf &
fi
if [ ${1} == "red" -a ${2} == "down" ]; then
        /usr/bin/killall igmpproxy

        /sbin/iptables -D CUSTOMFORWARD -s 193.158.35.0/24 -d 224.0.0.0/4 -i
        /sbin/iptables -D CUSTOMINPUT -d 224.0.0.0/4 -j ACCEPT -i wan-1
        /sbin/iptables -t nat -D CUSTOMPOSTROUTING -o wan-1 -j MASQUERADE

        /usr/bin/killall dhcpcd
        /sbin/vconfig rem wan-1
fi


DHCP ist so eingerichtet das der MR eine der IPs bekommt die in der igmpproxy.conf angegeben sind. In der Firewall hab ich IMGP, UDP, HTTP und NTP als ausgehenden Traffic erlaubt, und zugriff auf den IPCop für bootpc, bootps, DHCP und domain.

Meine erste freude kam auf als der MR endlich startet und nicht mehr die Meldung zeigte das er gestartet wird.

Leider bleibt dann nach ein paar Sekunden das Bild stehen, wenn der MR von UDP auf IGMP wechselt. Also schein etwas mit dem IGMP noch nicht ganz richtig zu sein.

Beim neustarten vom IPCop bekomme ich jetzt auch die Meldung das er für mon.wan-1 kein VLAN hinzufügen konnte, da das Gerät nicht vorhanden wäre.

Was muss ich jetzt noch anpassen damit es dann volständig funktioniert, im moment steht der IPCop noch auf statisch, da es dann einfacher ist Fernsehen wieder herzustellen in dem ich einfach nur einem Stäcker umstecke, soll später wieder auf ppoE umgestellt werden.

BdT
Varmandra


>edit<
Einen fehler habe ich gerade selber gefunden man sollte ausgeschlafen sein wenn man sowas macht...
falsches Interface im script benutzt nicht mon.wlan-1 sein sondern wan-1, hab es hier shcon korigiert, werde gleich mal den IPCop neustarten und schauen was dann ist.
>/edit<

>edit2<
Fehlermeldung beim neustarten hat sich geändert:
Code:
Starting interface RED ... ERROR: trying to add VLAN #0 to IF -:wan-1:-error: File exists

>/edit2<


Nach oben
   
BeitragVerfasst: 03.05.2013, 16:25 
Offline
Rookie
Themenstarter
Rookie
Benutzeravatar

Registriert: 11.04.2013
Beiträge: 8
Nach weiterem langem Suchen und lesen und Probieren habe ich jetzt die Lösung:

Für Speedport W722V und DSL16+ (VDSL25 sollte laut Aussage eines anderen genauso gehen)

Bei Einwahl keinen VLAN-Tag angeben.

IGMPproxy installieren

Dann in den Dateien folgendes einfügen (ACHTUNG: IPs und Interface Name müssen gegebenfalls angepasst werden)

/etc/rc.d/rc.event.local
Code:
# START IP-TV
if [ ${1} == "red" -a ${2} == "up" ]; then
        echo "RED up, Starting IP TV"
        /sbin/iptables -I CUSTOMFORWARD -s 217.0.119.0/24 -d 224.0.0.0/4 -i wan-1 -j ACCEPT
        /sbin/iptables -I CUSTOMFORWARD -s 193.158.35.0/24 -d 224.0.0.0/4 -i wan-1 -j ACCEPT
        /sbin/iptables -I CUSTOMFORWARD -d 224.0.0.0/4 -j ACCEPT
        /sbin/iptables -I CUSTOMINPUT -d 224.0.0.0/4 -j ACCEPT
        /usr/sbin/igmpproxy /etc/igmpproxy.conf &
fi
# END START IP-TV

# STOP IP-TV
if [ ${1} == "red" -a ${2} == "down" ]; then
        /sbin/iptables -D CUSTOMFORWARD -s 217.0.119.0/24 -d 224.0.0.0/4 -i wan-1 -j ACCEPT
        /sbin/iptables -D CUSTOMFORWARD -s 193.158.35.0/24 -d 224.0.0.0/4 -i wan-1 -j ACCEPT
        /sbin/iptables -D CUSTOMFORWARD -d 224.0.0.0/4 -j ACCEPT
        /sbin/iptables -D CUSTOMINPUT -d 224.0.0.0/4 -j ACCEPT
        echo "RED down, Stopping IP TV"
        /usr/bin/killall igmpproxy
fi
# END STOP IP-TV


etc/igmpproxy.conf
Code:
quickleave

phyint wan-1 upstream  ratelimit 0  threshold 1
        altnet 217.0.119.194/24 #T-COM
        altnet 193.158.35.0/24  #T-COM
        altnet 192.168.131.200 # Receiver

phyint unused-1 downstream  ratelimit 0  threshold 1
        altnet 192.168.131.200 # Receiver

        phyint lo disabled
        phyint ppp0 disabled
        phyint wan-1 disabled
        phyint lan-1 disabled
        phyint mon.wlan-1 disabled


Dann bei den Firewall-Regeln folgendes für den Reciver freigeben:
Ausgehender Traffic:
IGMP, http, ntp und UDP zum rotem Netz
Zugriff auf IPCop:
bootpc, bootps, IPCop dhcp und domain
(Hier ist der Reciver in einen grauem Netz (Extra Interfaces) welches bis auf die Freigaben geschlossen ist)


Wenn da jemand Verbesserungsvorschläge hat, bitte her damit, ansonsten wäre es sicher schick wenn man das unter 2.x.x - Anleitungen & FAQ einfügen würde/könnte.

BdT
Varmandra


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 2 Beiträge ] 

Alle Zeiten sind UTC+02:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu Forum:  
cron
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de