www.ipcop-forum.de


Deutsche IPCop-Community
CL-Systems
Home Home   Doku Doku   Links Links   Downloads Downloads
UnIPCop Der (Un)IPCop   IFS IPCop-ForumSpy
CopTime CopTime   Galerie IPCop-Galerie   IPCop Userkarte Userkarte
Aktuelle Zeit: 30.10.2014, 15:25

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]




Ein neues Thema erstellen Auf das Thema antworten  [ 4 Beiträge ] 
Autor Nachricht
BeitragVerfasst: 22.02.2012, 17:36 
Offline
Rookie
Themenstarter
Rookie

Registriert: 06.12.2008
Beiträge: 4
Wohnort: SE / SH
Moin Moin.

Nach langer Zeit habe ich mir mal wieder ein kleines Spielzeug angeschafft... :)

Folgendes Problem:

Während des Netzwerk-Setups wird die DFE-580TX einwandfrei erkannt.
Will ich Grün, Blau, Orange den Ports zuweisen klappt dies nur auf Port 1.
2, 3 und 4 werden ohne MAC-Adresse angezeigt.

Ifconfig zeigt mir auch nur die Grüne-Schnittstelle an.

Nanü? Habt Ihr eine Idee wie das kommt?
Auf meinem Futro S300 läuft die Karte einwandfrei.

Vielen Dank für eventuelle hilfreiche Tipps. :D

Gruß
flUNIX


Zuletzt geändert von flUNIX am 23.02.2012, 15:03, insgesamt 1-mal geändert.

Nach oben
 Profil  
 
BeitragVerfasst: 22.02.2012, 18:24 
Offline
Administrator
Administrator
Benutzeravatar

Registriert: 01.03.2004
Beiträge: 21763
[ -> 2.x.x - IPCop und Hardware ]

Thread verschoben.

_________________
1000 mm AFK


Nach oben
 Profil Website besuchen 
 
BeitragVerfasst: 23.02.2012, 10:52 
Offline
Rookie
Themenstarter
Rookie

Registriert: 06.12.2008
Beiträge: 4
Wohnort: SE / SH
Vielen Dank für das Verschieben. :)

Folgendes ist in der Systeminfo zu finden:

PCI-Geräte:

Code:
00:00.0 Host bridge [0600]: Transmeta Corporation TM8000 Northbridge [1279:0060]
00:01.0 PCI bridge [0604]: Transmeta Corporation TM8000 AGP bridge [1279:0061]
00:02.0 PCI bridge [0604]: ALi Corporation M5249 HTT to PCI Bridge [10b9:5249]
00:03.0 ISA bridge [0601]: ALi Corporation M1563 HyperTransport South Bridge [10b9:1563] (rev 20)
00:03.1 Bridge [0680]: ALi Corporation M7101 Power Management Controller [PMU] [10b9:7101]
00:0e.0 IDE interface [0101]: ALi Corporation M5229 IDE [10b9:5229] (rev c5)
00:0f.0 USB controller [0c03]: ALi Corporation USB 1.1 Controller [10b9:5237] (rev 03)
00:0f.1 USB controller [0c03]: ALi Corporation USB 1.1 Controller [10b9:5237] (rev 03)
00:0f.3 USB controller [0c03]: ALi Corporation USB 2.0 Controller [10b9:5239] (rev 01)
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE] [1002:5159]
02:05.0 Ethernet controller [0200]: VIA Technologies  Inc. VT6102 [Rhine-II] [1106:3065] (rev 8d)
02:06.0 PCI bridge [0604]: Intel Corporation 21152 PCI-to-PCI Bridge [8086:b152]
03:04.0 Ethernet controller [0200]: D-Link System Inc DL10050 Sundance Ethernet [1186:1002] (rev 15)
03:05.0 Ethernet controller [0200]: D-Link System Inc DL10050 Sundance Ethernet [1186:1002] (rev 15)
03:06.0 Ethernet controller [0200]: D-Link System Inc DL10050 Sundance Ethernet [1186:1002] (rev 15)
03:07.0 Ethernet controller [0200]: D-Link System Inc DL10050 Sundance Ethernet [1186:1002] (rev 15)


Netzwerkkarten:

Code:
02:05.0 Ethernet controller [0200]: VIA Technologies  Inc. VT6102 [Rhine-II] [1106:3065] (rev 8d)
        0200: 1106:3065 (rev 8d)
   Subsystem: 1106:0107
   Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx-
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 32 (750ns min  2000ns max)  Cache Line Size: 32 bytes
   Interrupt: pin A routed to IRQ 7
   Region 0: I/O ports at e000 [size=256]
   Region 1: Memory at ec200000 (32-bit  non-prefetchable) [size=256]
   Capabilities: [44] Power Management version 2
      Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+ D1+ D2+ D3hot+ D3cold+)
      Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
   Kernel driver in use: via-rhine
   Kernel modules: via-rhine

03:04.0 Ethernet controller [0200]: D-Link System Inc DL10050 Sundance Ethernet [1186:1002] (rev 15)
        0200: 1186:1002 (rev 15)
   Subsystem: 1186:1012
   Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx-
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 32 (2500ns min  2500ns max)  Cache Line Size: 32 bytes
   Interrupt: pin A routed to IRQ 5
   Region 0: I/O ports at d000 [size=128]
   [virtual] Expansion ROM at 40000000 [disabled] [size=64K]
   Capabilities: [50] Power Management version 2
      Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0- D1+ D2+ D3hot+ D3cold+)
      Status: D0 NoSoftRst- PME-Enable+ DSel=0 DScale=2 PME-
   Kernel driver in use: sundance
   Kernel modules: sundance

03:05.0 Ethernet controller [0200]: D-Link System Inc DL10050 Sundance Ethernet [1186:1002] (rev 15)
        0200: 1186:1002 (rev 15)
   Subsystem: 1186:1012
   Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx-
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 32 (2500ns min  2500ns max)  Cache Line Size: 32 bytes
   Interrupt: pin A routed to IRQ 10
   Region 0: I/O ports at d100 [size=128]
   [virtual] Expansion ROM at 40010000 [disabled] [size=64K]
   Capabilities: [50] Power Management version 2
      Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0- D1+ D2+ D3hot+ D3cold+)
      Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=2 PME-
   Kernel modules: sundance

03:06.0 Ethernet controller [0200]: D-Link System Inc DL10050 Sundance Ethernet [1186:1002] (rev 15)
        0200: 1186:1002 (rev 15)
   Subsystem: 1186:1012
   Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx-
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 32 (2500ns min  2500ns max)  Cache Line Size: 32 bytes
   Interrupt: pin A routed to IRQ 11
   Region 0: I/O ports at d200 [size=128]
   [virtual] Expansion ROM at 40020000 [disabled] [size=64K]
   Capabilities: [50] Power Management version 2
      Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0- D1+ D2+ D3hot+ D3cold+)
      Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=2 PME-
   Kernel modules: sundance

03:07.0 Ethernet controller [0200]: D-Link System Inc DL10050 Sundance Ethernet [1186:1002] (rev 15)
        0200: 1186:1002 (rev 15)
   Subsystem: 1186:1012
   Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx-
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 32 (2500ns min  2500ns max)  Cache Line Size: 32 bytes
   Interrupt: pin A routed to IRQ 7
   Region 0: I/O ports at d300 [size=128]
   [virtual] Expansion ROM at 40030000 [disabled] [size=64K]
   Capabilities: [50] Power Management version 2
      Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0- D1+ D2+ D3hot+ D3cold+)
      Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=2 PME-
   Kernel modules: sundance


Die Frage ist jetzt natürlich warum beim Netzwerksetup keine MAC-Adressen den Ports 2-4 zugewiesen sind.

Benötigt Ihr noch weitere Infos?

Was mir gerade noch aufgefallen ist... müssten nicht bei den letzten 3 Kontrollern folgendes stehen:

Kernel driver in use: sundance
Kernel modules: sundance

tätsächlich steht ja nur " Kernel modules: sundance ".

Gruß
flUNIX


Nach oben
 Profil  
 
BeitragVerfasst: 23.02.2012, 14:56 
Offline
Rookie
Themenstarter
Rookie

Registriert: 06.12.2008
Beiträge: 4
Wohnort: SE / SH
*PROBLEM GELÖST*

Mit folgenden Links bin ich dem Problem auf die Spur gekommen:

https://lkml.org/lkml/2007/5/4/376

und

http://www.efw-forum.de/www/forum/viewtopic.php?f=46&t=761

Anscheinend ist das ein BIOS-Bug bei meinem Gerät.

Nach dem Einfügen folgender Zeile:
Code:
setpci -s 02:06.0 3e.b=00


in der
Code:
/etc/rc.d/rc.sysinit


an folgender Stelle
Code:
PATH=/bin:/sbin:/usr/bin:/usr/sbin
Hier muss der Zusatz stehen
export PATH


läuft das Ganze nun schön rund und alles ist vorhanden und
arbeitet so wie es soll.

*Hinweis START*

02:06.0 ist meine PCI Bridge.

Auf anderen Geräten wird dies wohl anders sein.
Einfach mal " lspci " an der Konsole eingeben und dann schauen.

*Hinweis Ende*

Vielleicht hilft es ja jemanden irgendwann weiter... :)

Schönen Tag noch.

Gruß
flUNIX


Nach oben
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 4 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Group
Deutsche Übersetzung durch phpBB.de