IPCop-Forum.de

www.ipcop-forum.de


IPCop-Community
CL-Systems
Home Home   Doku Doku   Links Links   Downloads Downloads
UnIPCop Der (Un)IPCop   IFS IPCop-ForumSpy
CopTime CopTime   Galerie IPCop-Galerie   IPCop Userkarte Userkarte
Aktuelle Zeit: 26.05.2018, 15:24

Alle Zeiten sind UTC+02:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 2 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Keine Zustellung externer E-Mails
BeitragVerfasst: 21.08.2012, 14:01 
Offline
Apprentice
Themenstarter
Apprentice

Registriert: 22.08.2011
Beiträge: 19
Hallo,

mit meinem IPCop habe ich das Problem, dass E-Mails von außen nicht mehr zu unserem internen Mailserver zugestellt werden.

Folgendes Szenario:
(Interner E-Mailserver - IPCop - vorgelagerter E-Mailserver) - Internet

Soll heißen, dass alle E-Mails, die aus dem Internet an unser Haus gesendet werden, erst einmal einen vorgelagerten E-Mailserver passieren und dann an uns weitergeleitet werden. Schicke ich mir jedoch E-Mails an meine interne Adresse, kommen diese nicht an. Der vorgelagerte E-Mailserver meldet an meine externe E-Mailadresse:
Zitat:
Connection timed out


Auf dem IPCop steht in den /var/log/messages, wenn ich nach der IP des vorgelagerten Mailservers greppe:
Zitat:
Aug 16 13:02:00 [ipcop] kernel: RED DROP IN=wan-1 OUT=lan-1 SRC=[mail_außen] DST=[mail_innen] LEN=60 TOS=0x00 PREC=0x00 TTL=59 ID=53974 DF PROTO=TCP SPT=41693 DPT=25 WINDOW=5840 RES=0x00 SYN URGP=0


[ipcop], [mail_außen], [mail_innen] sind entsprechende Platzhalter.

Zum Test habe ich mein IPTables-Script auskommentiert und IPCop neugestartet. Über die Admin-Oberfläche habe ich eine Portweiterleitung eingetragen, die sich so niederschlägt:
Code:
iptables -t nat -nvL PORTFW
Chain PORTFW (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 DNAT       tcp  --  *      *       10.0.0.0/8           10.3.32.50           tcp spt:25 dpt:25 to:10.8.32.5:25


iptables -nvL PORTFWACCESS
Chain PORTFWACCESS (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 LOG        tcp  --  *      lan-1   10.0.0.0/8           10.8.32.5            tcp spt:25 dpt:25 limit: avg 10/min burst 5 LOG flags 0 level 4 prefix "ANY ACCEPT "
    0     0 ACCEPT     tcp  --  *      lan-1   10.0.0.0/8           10.8.32.5            tcp spt:25 dpt:25

10.3.32.50 = RED
10.8.32.5 = IP Mailserver

Via netstat wird mir am IPCop aber auch kein offener Port gezeigt - für SMTP müsste das ja 25 sein.

Der Versand ins Internet klappt einwandfrei.

Bin für jeden Tipp dankbar...

Grüße
Sven


Nach oben
   
BeitragVerfasst: 22.08.2012, 08:02 
Offline
IPCop-Entwickler, Site-Moderator
IPCop-Entwickler, Site-Moderator
Benutzeravatar

Registriert: 26.09.2003
Beiträge: 7810
Wohnort: Südhessen
Richte Deine Subnetze, 10.0.0.0/8 passt sowohl auf 10.3.32.50 als auch auf 10.8.32.5.

_________________
Sledgehammer engineering, if it doesnt work, hit it damn hard Bild

// Mein Cop, meine Signatur ^, meine Vorstellung
Most popular BOT FAQ: #5


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 2 Beiträge ] 

Alle Zeiten sind UTC+02:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu Forum:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de