IPCop-Forum.de

www.ipcop-forum.de


IPCop-Community
CL-Systems
Home Home   Doku Doku   Links Links   Downloads Downloads
UnIPCop Der (Un)IPCop   IFS IPCop-ForumSpy
CopTime CopTime   Galerie IPCop-Galerie   IPCop Userkarte Userkarte
Aktuelle Zeit: 12.12.2017, 15:00

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 3 Beiträge ] 
Autor Nachricht
BeitragVerfasst: 29.08.2014, 10:32 
Offline
Apprentice
Themenstarter
Apprentice
Benutzeravatar

Registriert: 15.04.2008
Beiträge: 21
Wohnort: Meiningen/Thüringen
Hallo liebe Forengemeinde,

bislang habe ich den IPCop V 1.4.21 (RED/GREEN) in der "Zone Grün" mit einer reinen Windows-Server-2012-R2-Domäne mit Windows 8.1 Clients betrieben. Mit Hilfe einer Gruppenrichtlinieneinstellung "Netzwerksicherheit: LAN Manager-Authentifizierungsebene LM- und NTLM-Antworten senden (NTLMv2-Sitzungssicherheit verwenden, wenn ausgehandelt)" war die Benutzerauthentifizierung über das AD möglich und die Protokollierung des Benutzernamens im Advanced Proxy funktionierte einwandfrei.

Jetzt bin ich auf die IPcop V. 2.1.5 umgestiegen, habe alle Konfigurationsparameter des "alten" IPCop in den Web-Proxy übernommen und jetzt funktioniert die Authentifizierung nicht mehr. D. h., wenn der Benutzer über den Webbrowser (egal ob IE, FireFox oder Chrome) auf Internetinhalte zugreifen möchte, poppt ein Fenster auf mit der Aufforderung, sich am Proxy zu authentifizieren.

Als Authentifizierungsmethode ist im Webproxy "Windows" ausgewählt und auch die Konfig-Einstellungen zu "Domäne", "PDC" und "BDC" habe ich aus dem "alten" IPCop übernommen. Die Proxy-Einstellungen bezüglich des Ports von alt: 800 auf neu: 8080 werden mittels Gruppenrichtlinien ausgebracht und auch auf allen Clients sauber umgesetzt. Schalte ich die Authentifizierung ab, können die Benutzer auf Internetinhalte zugreifen.

Ich habe auch versucht, die Gruppenrichtlinie "Netzwerksicherheit: LAN Manager-Authentifizierungsebene LM- und NTLM-Antworten senden (NTLMv2-Sitzungssicherheit verwenden, wenn ausgehandelt)" abzuhängen. Das Ergebnis bleibt jedoch unverändert.

Ich habe dann versucht, die Authentifizierungsmethode über "LDAP" laufen zu lassen. Hier wird dann zwar der Benutzername und die aufgerufene Website im Web-Proxy, wie gewünscht, protokolliert, aber der Benutzer bekommt am Client nicht den aufgerufenen Webseiteninhalt angezeigt, sondern die Aufforderung, sich am Proxy zu authentifizieren. Auch eine Eingabe der Benutzeraccount-Daten hilft hier nicht weiter.

Ich bin etwas ratlos. Eigentlich wollte ich den alten IPCop ersetzen, weil mir die Funktionen der neuen IPCop-Version viel besser gefallen. Allerdings ist die Protokollierung der Benutzer bei uns notwendig und ohne eine Lösung kann ich den "alten" IPCop nicht ablösen.

Ich hoffe auf eure Unterstützung. Vielen Dank im Voraus.

Gruß, zeptor74

_________________
reboot - be root


Nach oben
   
BeitragVerfasst: 30.08.2014, 10:53 
Offline
Administrator
Administrator

Registriert: 01.03.2004
Beiträge: 22218
Du scheinst eine wirklich passende/ideale Umgebung zur Verfügung zu haben.

weizen_42 hatte zu diesem Thema eine Lösungsmöglichkeit im Sinn, die ich leider
bei uns nicht umsetzen konnte. Vielleicht hat weizen_42 Lust und Muße das
Thema noch einmal anzugehen, wenn Du dich als motivierter, zuverlässiger Test-
kandidat zur Verfügung stellst, Zeit investierst und entsprechendes, ausführliches
Feedback lieferst. Sprich ihn einfach einmal an, gehe die Sache aber gelassen und
ohne große Erwartungen an.


Nach oben
   
BeitragVerfasst: 22.09.2014, 15:59 
Offline
Constable
Constable

Registriert: 27.03.2009
Beiträge: 39
Ich habe hier ein relativ ähnliches Setup, allerdings mit einer Win 2K8 Domäne. Läuft soweit, hatte aber mal ein ähnliches Problem, als die Basis-DN falsch angegeben war bzw. der User in der AD sich oberhalb davon befunden hat, was ja ansich auch logisch ist.

Sind die Clients die auf den Proxy zugreifen alle im selben Netzsegment?


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 3 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu Forum:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de