IPCop-Forum.de

www.ipcop-forum.de


IPCop-Community
CL-Systems
Home Home   Doku Doku   Links Links   Downloads Downloads
UnIPCop Der (Un)IPCop   IFS IPCop-ForumSpy
CopTime CopTime   Galerie IPCop-Galerie   IPCop Userkarte Userkarte
Aktuelle Zeit: 25.02.2017, 23:37

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 4 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: IPCop VLAN tagging ????
BeitragVerfasst: 10.01.2017, 11:12 
Offline
Rookie
Themenstarter
Rookie

Registriert: 01.05.2012
Beiträge: 4
Hello
I am about to get internet over fibre. The ISP requires a pppOE connection on the red interface with VLAN tag (10).

I have found and installed the VLAN tag addon (vlan-ipcop-0.2.0) and the Extra Interfaces addon (xtiface-ipcop-1.0.3).

I found a post http://www.ipcop-forum.de/forum/viewtopic.php?f=57&t=26035 that recommends not installing these addons because of security concerns but I need VLAN tagging. Is there an secure alternative to the addons????

After installing the addons, I can't find the GUI displayed on the SourceForge page. The Extra interfaces gui is there, but not the VLAN tagging gui. I did find the extra section in the dialup GUI that includes VLAN tagging. When installed, there were no error messages. This is different to the
standard" GUI shown in the IPcop manuals.

This image shows my dialup GUI. You will need to follow the link to get a hi res image.
http://i205.photobucket.com/albums/bb24 ... %20tag.png


Nach oben
   
 Betreff des Beitrags: Re: IPCop VLAN tagging ????
BeitragVerfasst: 10.01.2017, 19:32 
Offline
Superintendent
Superintendent

Registriert: 05.06.2009
Beiträge: 593
Wohnort: Nordlicht im Ländle
Hi dazz,

I have changed from ADSL (without VLAN tagging) to VDSL (with VLAN 7 tagging) dialup just a month ago. I am using PPPoE without having installed any related addon.

My connections settings are quite similar, but not identical:
  • Reconnection: like yours, but 100 retries (increased from default value due to modem hardware issues with in the past)
  • Additional PPPoE settings: like yours, but VLAN tag 7 which is specific for my connection
  • Authentication: user name and password are missing. I suspect that these have to be filled in.
  • DNS: like yours

Please also check the log entries (system protocol) for "Red". Here you should see entries like this, when you are using incorrect authentication credentials:
Code:
21:40:53   red   Starting RED device wan-1 type PPPOE.
21:40:53   red   Dialling 1und1.
21:40:53   pppd[8119]   Plugin rp-pppoe.so loaded.
21:40:53   pppd[8119]   RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
21:40:54   pppd[8122]   pppd 2.4.7 started by root, uid 0
21:40:54   pppd[8122]   PPP session is 13867
21:40:54   pppd[8122]   Connected to 00:30:88:1f:0e:38 via interface wan-1.7
21:40:54   pppd[8122]   Using interface ppp0
21:40:54   pppd[8122]   Connect: ppp0 <--> wan-1.7
21:40:54   pppd[8122]   Remote message: 0034 PSSTG001 0004947825 profile not sufficient
21:40:54   pppd[8122]   PAP authentication failed
21:41:00   pppd[8122]   Connection terminated.
21:41:00   pppd[8122]   Modem hangup
21:41:00   pppd[8122]   Exit.


If you are using incorrect VLAN tagging, it looks like this:
Code:
21:13:25   red   Starting RED device wan-1 type PPPOE.
21:13:25   red   Dialling 1und1.
21:13:25   pppd[7113]   Plugin rp-pppoe.so loaded.
21:13:25   pppd[7113]   RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
21:13:26   pppd[7116]   pppd 2.4.7 started by root, uid 0
21:14:01   pppd[7116]   Timeout waiting for PADO packets
21:14:01   pppd[7116]   Unable to complete PPPoE Discovery
21:14:01   pppd[7116]   Exit.


Having both correct VLAN tagging as well as authentication, my system protocol looks like this:
Code:
21:47:52   red   Starting RED device wan-1 type PPPOE.
21:47:53   red   Dialling 1und1.
21:47:53   red   ppp device node created
21:47:53   pppd[8638]   Plugin rp-pppoe.so loaded.
21:47:53   pppd[8638]   RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
21:47:54   pppd[8641]   pppd 2.4.7 started by root, uid 0
21:47:54   pppd[8641]   PPP session is 1287
21:47:54   pppd[8641]   Connected to 00:30:88:1f:0e:38 via interface wan-1.7
21:47:54   pppd[8641]   Using interface ppp0
21:47:54   pppd[8641]   Connect: ppp0 <--> wan-1.7
21:47:54   pppd[8641]   Remote message: [UI-SBR:,20000;]
21:47:54   pppd[8641]   PAP authentication succeeded
21:47:54   pppd[8641]   peer from calling number 00:30:88:1F:0E:38 authorized
21:47:54   pppd[8641]   local IP address 79.213.XX.XX
21:47:54   pppd[8641]   remote IP address 217.0.117.175
21:47:54   pppd[8641]   primary DNS address 217.237.151.142
21:47:54   pppd[8641]   secondary DNS address 217.237.150.188


Regards, zargano


Zuletzt geändert von edelweis am 10.01.2017, 20:07, insgesamt 1-mal geändert.
Öffentl. IP maskiert


Nach oben
   
 Betreff des Beitrags: Re: IPCop VLAN tagging ????
BeitragVerfasst: 11.01.2017, 06:58 
Offline
Rookie
Themenstarter
Rookie

Registriert: 01.05.2012
Beiträge: 4
Hi
Thanks for the info.
When I did the screen shot, I hadn't filled in all the info.
Based on your experience, I will reinstall IPCop on my CF card to ensure no trace of the addons remains.

The extra interfaces addon works as advertised but I don't need that feature.
The VLAN tagging addon has not added the GUI page.

It will be a few weeks before fibre is installed so I will aim to report back then.

Regards

Dazz


Nach oben
   
 Betreff des Beitrags: Re: IPCop VLAN tagging ????
BeitragVerfasst: 12.01.2017, 19:21 
Offline
Superintendent
Superintendent

Registriert: 05.06.2009
Beiträge: 593
Wohnort: Nordlicht im Ländle
@edelweis: thanks for masking my public IP address. This is indeed good practice, and I overlooked to do this. The good (or the bad?) news is that my provider 1&1 drops the connection after 24 hours. As a consequence, I get a new public IP address every 24 hours...

zargano


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 4 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu Forum:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de